Page 1 of 1

Problem with gl-rpi-1.00.py

PostPosted: Thu Oct 27, 2016 8:57 pm
by Domenico
I've just tried to use the Griblinks with raspberry pi 3, but when I launch the "gl-rpi-1.00.py" file from Putty serial console there are different error message (from Rpi Python idle too)
May someone check the script with raspberry 3 ?

Re: Problem with gl-rpi-1.00.py

PostPosted: Mon Jan 02, 2017 11:55 pm
by cjoubert
Hello,
I have the same problem with a Rspberry pi zero and pi 2.
Maybe the problem is on the line response = urllib2.urlopen(url).read(). It s did'nt work with an url who countain a symbol & or ? .

On my raspberry, when I use
Code: Select all
wget -O test.txt 'http://www.techtinker.co.za/griblinks/getswstatusrpi.php?EMAIL=xxxxxxxxxx@gmail.com&SECRET=xxxxxxxxxxxxxxxxx' ; cat test.txt
It return SW0:|,SW1:|,SW2:|,SW3:|,SW4:|,SW5:|,SW6:|,SW7:|,SW8:|,SW9:|,SW10:|,SW11:|,SW12:|,SW13:|,

Thank's for your help.